Classicamiga Forum Retro Edition
1 2 3
Thread: I got an AmigaOne XE G4
Stephen Coates 18:20 20th June 2016
I always fancied an AmigaOne of some kind. So, a few months ago, I bidded on one which came up on eBay, and won it for about 100 . It included the XE G4 motherboard, a graphics card, an IDE card, and a copy of AmigaOS 4.1.

I haven't built it up into a working system yet (due to lack of components), but I did pinch the PSU from my main PC just to test it, and confirm that it does indeed work.

After sitting around for a bit, I finally managed to get an ATX case for it. I was looking for something quite small, so I eventually settled on a Powercool 3060, which is quite small for a full ATX case. It got it for about 20. Its clearly not as well built as my main PC's Lian Li case, but it's still quite nice.

Now I just need to get a PSU and an IDE hard drive (or maybe I should use compact flash/SSD?). I can probably recycle a CD/DVD drive and a floppy drive from my spare parts collection.

I reckon I'll be having plenty of fun with this

Here's the Powercool case (which can be used either as a desktop or tower):


Rear of the case with the motherboard fitted:


Motherboard inside the case (but with no processor):


The CPU card:



Harrison 01:11 21st June 2016
Yoy got that for a nice price. Definitely use a SSD if you can.

Sent from my SM-G900F using Tapatalk
Kin Hell 09:06 21st June 2016
Well done fella. You got yourself a bit of a bargin there.
Stephen Coates 15:10 21st June 2016
I was surprised I managed to get it at a good price, as I have seen them go for much more in the past. Do they tend to sell for much these days? Now that there are newer/more modern AmigaOne models, I'd expect these to loose their value. Also, these G3/G4s do have a reputation for being a bit unreliable, although the seller did say that this one had been very stable.

Funny to think that these are now 13 years old .

Don't suppose anyone has a spare ATX PSU that they don't want?

Is there much available in terms of IDE SSDs? Can't say I pay much attention to SSDs as I use hard disks pretty much everywhere.
Harrison 10:03 23rd June 2016
An alternative is an ide to sata adapter.

Sent from my SM-G900F using Tapatalk
Kin Hell 14:39 26th June 2016
Originally Posted by Stephen Coates:

Funny to think that these are now 13 years old .

Not so funny when I think back to buying my Amiga 3000D 26 years ago @ the tender age of 28....

I do have an ATX kicking about if you're interested? - Antec True 550P <----click me!

There is a 5.25" drive bay that comes with it. The PSU has a small plugged wire array that goes to this drive bay. On the front right corner, you can adjust the 12, 5 & 3.3V rails with a little pull out tool in the front panel. you can also fit a 3.5" device (Floppy, card reader) into the drive bay.

It's heavy (Quality kit back in the day) but I don't have the original box for it, sry. - I'll find out the shipping costs for you if you PM me your delivery address details.


Bah! - I just tried my PSU tester on it & it's failed. It was okay when it went into store. I tried another 600W Corsair I have & that passes, so it isn't my tester at fault. Really sorry fella.
Stephen Coates 12:38 20th October 2016
Time for an update.

I bought some parts for it a while back and got it all fitted in the case. I opted for a cheap refurbished IDE HDD in the end, and I got a Corsair PSU (can't remember the model off the top of my head).

I had a play with the OS 4.1 which came with it, but I also recently bought a copy of OS 4.1 Final Edition from AmigaKit. It was nice and easy to install.

Unfortunately, I'm having difficulty with it. When it boots up, it gets stuck on a blank Workbench Screen. Fortunately You can hold the mouse buttons down on boot up to get the option of booting without a startup-sequence, like you can on a classic Amiga.

After commenting various things out in the startup-sequence, I narrowed it down to a problem with LoadMonDrvs, which is something to do with the graphics card drivers. I expect I'll be able to sort it out, but I haven't had chance to play with it any more yet.

Meanwhile, here's a few pictures.

This is the blank Workbench Screen which it gets stuck at on boot up.


Here's the early startup control:




This is the Kickstart screen which displays if no boot device is selected:


AmigaOS 4.1 FE booted with no startup-sequence:


Editing the startup-sequence in Ed:

Stephen Coates 03:21 3rd December 2017
I still haven't found out why it boots to the blank screen. All I can say is that its some sort of issue with the Radeon 7000 driver.

I tried a PCI VooDoo 3 3000 card and put the VooDoo driver into Devs:Monitors/ and it works perfectly. Had to have a little fiddle to get it to recognise my monitor's 1920x1200 resolution, but it seems to work fine.

No idea what's wrong with the Radeon driver.

I think the next thing to do will be to find a better heatsink for the processor. The tiny fan that is mounted on it is far too noisy.

Harrison 01:11 5th December 2017
Strange. Are you sure the graphics card is ok? At least you can get it working witg the other one.

Sent from my SM-G950F using Tapatalk
Stephen Coates 03:41 7th December 2017
Don't know if the graphics card is OK or not. It obviously works to an extent though. I'll try the card in a PC sometime and test it.

I think I might see about getting a more powerful AGP graphics card.
1 2 3