Classicamiga Forum Retro Edition
1 2 3 4
Thread: My Garage A1200 find
Aughie 21:50 9th June 2015
I was recently clearing out my garage and found a box with my old A1200. There was also two hard drives. One a 3.5 x 4gig IDE which used to reside in my a1200 tower which I dont have any more DONT ASK!. Also a 2.5" x 4 gig ide which as far as I remember was blank. However there were no leads PSU or any disks. I found and ordered an A500 PSU online plus found a gadget which proported to allow old computers to use a PS2 mouse. I am awaiting a 23pin to Scart lead plus a 44 pin to 40 pin IDE lead so I can try to boot the 3.5 drive.

The only bits that have arrived so far were the PSU & the said 9 pin to PS2 convertor. IT DID NOT WORK I instead have ordered a genuine Amiga mouse.

Also when I plugged in the A500 PSU nothing happened no power light nothing.

I could hear it humming when I held it up to my ear so it seemed to be OK. I opened it as I saw there is a fuse in them but it was fine.

In desperation I then stripped my A1200 completely removing the shield in case there was a fuse or somthing in under there. Nothing so I reassembled it all and plugged it in again. Lo & behold this time all worked perfectly.

There was quite a bit of HD activity before it settled down but as the 23 pin to Scart cable hasnt arrived yet I have no idea what that means. I really thought this was a blank 2.5" HD. The disk drive clicks which I assume is another hopeful sign.
Harrison 00:35 10th June 2015
Hi and welcome to CA. The A1200 also has a colour composite video output on the back so whilst waiting for the SCART cable you could plug the Amiga into most TVs using the composite output. You just need a standard yellow phono cable. Most people have some as they come bundled with most TVs, DVD players, games consoles etc.
Aughie 23:05 10th June 2015
My mouse and scart lead arrived together today and there is indeed a workbench on the 2.5" drive I thought was empty. However the whole system boots straight into something called Parbench boot script by Vernon Graner, which hogs the whole system for ages and allows nothing else to be done. There is no tick box to stop it.I am forced to wait until the prog finished whatever it was doing and I haae WB back again However the keyboard didnt operate as I fired up Wordworth but no response. I took it apart and the ribbon cable seemed quite loose soI fiddled until it went in firmly. I fired up Emacs but it cannot any Parbench entries in either the startup sequence or the user startup so im stumped. It appears to be trying to get my amiga online

How do I stop this Parbench thing? PS I forgot to say the gadget I left the pic of is for a Windows PC (SAME MODE OF ATTACHMENT)as they once had serial mice but were wired differently to our meeces hence its failure

I googled Parbench

This seems to list where Parbench puts its files. Perhaps I could use this to manually remove it or if I can find the Utilities drawer I should be able to end the programme

- - - Updated - - -

Originally Posted by :

This seems to list where Parbench puts its files. Perhaps I could use this to manually remove it or if I can find the Utilities drawer I should be able to end the programme
Did the above and hey presto no more Parbench. I boot straight into Power Workbench!!
Kin Hell 13:39 11th June 2015
Parbench & Parnet just use the Amiga's Parallel Port to network to other computers. It wouldn't get you onto the Internet.
The Parallel port achieves a faster Baud rate than the Serial port.

Back in the early '90's, I used Parnet to hook up my Amiga CDTV & A4KD so I could access CDROM's.

Well done for sussing out it's removal.
Aughie 22:02 11th June 2015
I have discovered a new problem. I started Final Writer and was typing away but noted the left shift key dosent work. So no "$%^& symbols. I tried Wordworth same results. I think I have damaged the ribbon cable. Has anyone on here had this problem on their A1200 and how do you fix it?
Stephen Coates 07:54 12th June 2015
Can you see any damage on the ribbon cable? Here is a photo of one of my damaged ribbon cables:
Some of the conductive material has worn off on some of the pins, so it doesn't work properly.

If you can't see any damage on that part, it could be that the membrane inside the keyboard has become damaged or worn with time.

If you haven't already done so, it might be worth having a little poke around the connectors just to make sure they aren't dirty.
Harrison 08:02 12th June 2015
You might not have pushed the keyboard ribbon connector in far enough or got it straight. It's quite a fiddly connection. Lift the outer plastic locking mechanism up at both sides and then push the ribbon connector fully into the slot making sure it's straight and fully inserted, then push the locking collar down evenly at both sides.
Aughie 09:38 12th June 2015
I feel a right chump. I didnt even know there was a locking collar. I just tugged the connector in and out. Also the pics of the damaged ribbons wont show on my computer as it reports there are errors with the file and cannot display it.

Is there any successful way to fix this if I have broken a connection. Also how do you clean the connector as it seems like it would be very tricky to get any crud out of it if any was lodged down there.
Kin Hell 10:49 12th June 2015
Wouldn't worry about cleaning it. Lift the collar carefully without pulling it clean off. It lifts about 2 to 3mm

Remove keyboard cable & look for no splits or frays.

Refit firmly with light pressure & try not to press the collar before you feel the ribbon bottom out in the slot.

Re-seat the locking collar down to finish.

The chances are the cable wasn't in properly for how you removed it. They come out ok but much harder on the way in with the collar seated.

Also, try to get into the habit of NOT plugging & unplugging peripherals into your miggy when she's powered on. CIA chips have been known to die for doing this.
Stephen Coates 10:52 12th June 2015
I've not succeeded in repairing the damage in the photo (not sure why the photo doesn't work for you; it works fine here).

If the ribbon cable connector is dirty, you could clean it with a bit of alcohol and a cotton tip or a cloth, but don't do this too often otherwise you might wear out the contacts. As for cleaning the connector on the motherboard, I'm not sure. Maybe just check that there's no dust in it .

Have fun with it . I don't seem to have much success with Amiga keyboards. I have several spare dodgy ones.
1 2 3 4