Classicamiga Forum Retro Edition
Thread: Goal! Disk 2 problem
camurso_ 10:52 29th September 2014
Hi guys!
I have an Amiga 500 with Ram 1MB and I have a Cortex Amiga Floppy Drive Emulator installed.
So, as I try to play a match on Goal!, whenever I get asked to insert disk 2 the game never moves on.
It just keeps asking me for disk2.
I tried various Goal! releases from various sites (TOSEC, ROM sites, Abandonware, etc) and always got this problem.
I have played many multi disk on my drive and many games which require 1MB Ram.

Did something like this happen to anybody?

Thank you and sorry my bad English.
Harrison 13:30 29th September 2014
Your English is fine so don't worry about that.

I've got a Gotek Floppy drive emulator in my A600 so can test the game for you when I get time and see if I can get a copy of disk 2 to run. It might be that this specific game just doesn't like the floppy emulator.. I expect there must be some that don't like the firmware. An alternative could be to use WHDLoad on a HD in your Amiga to run the game if you have one? If you don't I have one for sale if interested..
camurso_ 13:49 29th September 2014
Thank you for your reply.
Unfortunately A500 does not support HDLoad, to my knowledge.
Harrison 14:13 29th September 2014
You can use WHDLoad with an A500, but you need some fast ram and a HDD. As it runs on the A600 perfectly well with 4MB total ram (some games even work on 2MB) there is no reason it won't run on the A500 with some fast ram.

The only other thing I'm trying to remember is which version of kickstart would be needed. Maybe 2.04? Would need to check that as I run my A600 in KS3.1.