Classicamiga Forum Retro Edition
Thread: WinUae probs...
Khephren 12:16 25th February 2011
Hi everyone, so WinUae no longer functions on my PC, it hangs on 'direct input.. Game controllers..' (none are plugged in), DXdiag also falls over on DXinput. I think I need to reinstall DirectX, but of course, it is now integral to Vista, and not a seperate dwnload.

I've been writing some info in another thread about Amiga graphics, but it's now difficult without winUae (and winfellow won't read my HDF). Does anyone know if E-UAE is available for windows?

any help would be appreciated!
[Reply]
Harrison 15:05 25th February 2011
I think WinUAE uses DirectX 9 still, and not 10 or 11. In Vista and Win7 you still need to have both DX9 and DX10 installed. As you say, DX10 is part of the OS, but DX9 isn't, and a lot of older gamers still require it to be installed in addition to the default version 10 to work. Try downloading the latest version of DX9.0c again and installing it.

Have you also tried an older version of WinUAE? I've also had issues sometimes with one version of WinUAE not working, and have reverted to an older release and it then functions correctly. We have the WinUAE downloads in our downloads section (Downloads link in menu at top of site) if you want to try a different version. If you can't access the downloads section PM me and I will upgrade your membership.
[Reply]
Khephren 18:41 25th February 2011
Hi Harrison,
Yeah I tried an old version, no joy
however, thanks for the lead on DX9 and DX10 being two different things. I'll give DX9c a go. This whole direct X thing is getting a bit confusing!
[Reply]
Khephren 15:31 26th February 2011
It was my Aiptek graphics driver causing all the fuss. I've disabled it until I need to use it. Now X3 Reunion runs as well!

ta,

Mark.
[Reply]
Tags:Array
Up