Classicamiga Forum Retro Edition
1 2
Thread: Netsurf
TiredOfLife 12:10 25th August 2008
A new OS4 browser capable of displaying CSS pages correctly.

Currently in alpha stage but looking good.
Some bugs that it currently has displaying some pages on forums have already been corrected by the author, so hopefully another release will arrive shortly.

Unlike OWB Blastoise and OWB DoDuo, Netsurf works well on a Blizzard or Cybervision PPC.

OWB Blastoise is much slower and OWB DoDuo is currently Amigaone only because of the memory needed.

Netsurf as well as being much swifter, currently needs little in the way of memory.

Netsurf is available at Aminet.
Harrison 15:31 8th September 2008
Sod OS4. I want an up to date browser to be developed for Workbench 3.1!!!

After all, more people are still using 3.1 to 3.9 than they are OS4, so there is more demand. Somehow unless a decent Amiga One emulator is every released I don't see myself ever using OS4.
Buleste 14:29 18th November 2009
Now that netsurf is supposedly WB3 compatable has anyone managed to get it to work with winuae (I don't think anyone has a 100mhz 060)?
Buleste 19:01 30th November 2009
I've managed to get the latest version of netsurf to start under winuae but then I get a software failure when I try to type anything into google or the Url bar. It could be my truetype font handler but has anyone else tried it yet and if so have they had any better luck?

EDIT: Just made sure I have the latest full version of Winuae and have downloaded the dejavu fonts and installed them onto my system drive. started up, managed to type "classic amiga" into the google page and then it crashed. still it's slightly further than before (doesn't work in 060 mode just 040).

EDIT2: I managed to get onto the forum and tried to save some screenshots and edit this post but it's more unstable than (please insert sick joke about someone in the news recently who has been unstable. The clean version is Susan Boyle but please be as sick as you want....just keep it to yourself).

EDIT3: I've reinstalled the type1 engine version 3.1 and it is a bit more stable but I still can't edit posts on this site and a few errors on the main site. However I've made some images so the web guru's can have a look.

Harrison 11:08 1st December 2009
Great work. Nice to see it finally working. The CA homepage error with the images appearing under each other happens when Javascript (Ajax) is disabled in a browser.

It is great to see CSS working correctly in an Amiga browser. The top menu part of the forum for example is completely built using CSS.

Something I noticed, unrelated. You still have a very old notice at the top of the forum homepage. Click the red X in the top right of the wondow and it will remove it forever.

This has got me tempted to try this browser out now. So what do I need to install?

Can you give me a list of what is needed and links?
Buleste 11:44 1st December 2009
You need a type1 font manager which is more than likely installed in one of the WB packages. If it isn't try this.

The fonts can be downloaded from here (although the fonts also come with Netsurf it's better safe than sorry).

And netsurf can be found here.

The font manager and netsurf have their own install programme and just unpack and copy the fonts to the system:fonts drawer.

One word of warning...installing netsurf can cause ibrowse to fail.
Harrison 12:12 1st December 2009
I will give it a try in a clean install of Wokbench then, so it doesn't mess anything up in my main setups.
Buleste 20:14 8th February 2010
There is a new version of Netsurf 68k out. Unfortunately it doesn't like the forums when you log in but it still works alright.
Buleste 10:15 9th February 2010
A updated version is now on aminet and it now works with this forum. So much so that this post has been made using netsurf. WOOT
Harrison 11:51 9th February 2010
That is excellent news. Finally a classic Amiga browser that works.

However, looking at the requirements, it needs quite a high end 68K Amiga to run. How fast is it on your setup? And is your setup still as your sig with an overclocked 040?

Sadly I don't have a graphics card in my A4000 so can't try this on a real Amiga. But will be firing up the emulation later to check it out.
1 2